Chatbot: Rasa関連ライブラリのバージョン調整 ver.1

Last Updated on

RasaはPythonで使用できるチャットボットのフレームワークです。

クラウドではなく、ローカルにインストールするものですが、依存パッケージのバージョンのバージョンコントロースのためのリンク集です。随時更新します。

エラー表示をみて個別に対応しています。一つをダウングレードすると、別のライブラリと不整合になるということがよくおこります。

 

Rasaのインストールとバージョンの調整で参照するページのリンクを掲載します。

 

How to Build a Chatbot with RASA : Complete Guide

 

pip install rasa_nlu

pip install -U spacy

python -m spacy download en

pip install rasa_core

 

Kernel crashes with ModuleNotFoundError on ‘prompt_toolkit.formatted_text’

 

pip install ‘ipykernel<5.0.0’

 

pip install ‘prompt_toolkit==1.0.14’

 

pip install ‘prompt_toolkit==1.0.14’

About shibatau

I was born and grown up in Kyoto. I studied western philosophy at the University and specialized in analytic philosophy, especially Ludwig Wittgenstein at the postgraduate school. I'm interested in new technology, especially machine learning and have been learning R language for two years and began to learn Python last summer. Listening toParamore, Sia, Amazarashi and MIyuki Nakajima. Favorite movies I've recently seen: "FREEHELD". Favorite actors and actresses: Anthony Hopkins, Denzel Washington, Ellen Page, Meryl Streep, Mia Wasikowska and Robert DeNiro. Favorite books: Fyodor Mikhailovich Dostoyevsky, "The Karamazov Brothers", Shinran, "Lamentations of Divergences". Favorite phrase: Salvation by Faith. Twitter: @shibatau

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.